Разбор стэка MES2324FB проблема

MES, ESR
Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:00

Был стэк из двух MES2324FB.Обновил до прошивки 4.13.3. Разобрал стэк по мануалу:
1) На master сбросить конфигурацию стека. Командой (config)# no stack configuration
2) На master зайти в режим конфигурации unit-а 2. Командой (config)# stack unit 2
3) Сбросить конфигурацию стека. Командой (unit)# no stack configuration
4) Затем зайти в режим конфигурации unit-а 3. Командой (config)# stack unit 3
5) Сбросить конфигурацию стека. Командой (unit)# no stack configuration
6) Перезагрузить стек. Командой # reload

Все интерфейсы с индексом 2 ушли(т.е. interface gigabitethernet2/0/X).
Решили на эти коммутаторы водрузить VPC, настроили по схеме как указано в базе знаний. Схема такая же, как и в базе знаний.
И когда настраивал Port-chennel2 то увидел, что на одном из MES2324FB остался порт с индексом 2:

interface gigabitethernet2/0/24
media-type force-copper
description Uplink_backup_C3560
spanning-tree disable
switchport mode trunk
switchport trunk allowed vlan add 503,508-509,531-540,548,612,630
switchport forbidden default-vlan
exit

Т.е. кусок от стэка. Что я сделал ни так? и Как это можно полечить?

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:14

Отключил VPC командой no vpc.
Сбросил настройки этого порта командой default interface G 2/0/24 и перезапустил.
Порт с индексом 2 исчез, но при конфигурировании любого другого порта с индексом 2 разрешает.
Такое впечатление, что коммутаторы до сих пор думают, что они в стэке и видят второй юнит.

SW_OIT_SFP2#conf
SW_OIT_SFP2(config)#int G 2/0/2
SW_OIT_SFP2(config-if)#

SWG_OIT_SFP1#conf
SWG_OIT_SFP1(config)#int G 2/0/14
SWG_OIT_SFP1(config-if)#

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:15

Код: Выделить всё

SWG_OIT_SFP1#sh run
vlan database
 vlan 503,508-509,531-540,548,612,630
exit
!
port jumbo-frame
!
loopback-detection enable
loopback-detection interval 10
loopback-detection vlan-based
loopback-detection vlan-based recovery-time 60
!
errdisable recovery interval 120
errdisable recovery cause loopback-detection
errdisable recovery cause stp-bpdu-guard
errdisable recovery cause stp-loopback-guard
errdisable recovery cause unidirectional-link
errdisable recovery cause storm-control
!
vpc
vpc domain 1
 peer detection
 peer detection interval 200
 peer detection timeout 700
 peer detection ipaddr 10.80.3.45 10.80.3.44
 peer keepalive
 peer keepalive timeout 2
 role priority 5
 peer link Port-Channel 1
exit
!
vpc group 1
 domain 1
 vpc-port Port-Channel 2
exit
!
!
hostname SWG_OIT_SFP1
!
line console
 exec-timeout 30
exit
!
line ssh
 exec-timeout 15
exit
!
username root password encrypted 0eb3d6ceb65c5f7f938ba393c4d667a2fe7b269e privilege 15
username admin password encrypted 81fd928162cdd2149ba3db96914f245abd8ac3a0 privilege 15
!
ip ssh server
!
no ip telnet server
!
interface gigabitethernet1/0/1
 description FOR_CTT
 switchport mode trunk
 switchport trunk allowed vlan add 503,535,540
exit
!
interface gigabitethernet1/0/10
 description CTT
 switchport mode trunk
 switchport trunk allowed vlan add 503,535,540
exit
!
interface gigabitethernet1/0/11
 ip address 1.1.1.1 255.255.255.252
exit
!
interface gigabitethernet1/0/24
 channel-group 2 mode auto
exit
!
interface tengigabitethernet1/0/3
 channel-group 1 mode auto
exit
!
interface Port-channel1
 switchport mode trunk
 switchport trunk allowed vlan add 503,508-509,531-540,548,612,630
exit
!
interface vlan 1
 no ip address dhcp
exit
!
interface vlan 503
 name L2_CONTROL_AMURGEN_BTEC
 ip address 10.80.3.44 255.255.255.0
exit
!
!
ip default-gateway 10.80.3.1
!
end
SWG_OIT_SFP1#

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:15

Код: Выделить всё

SWG_OIT_SFP2#sh run
vlan database
 vlan 503,508-509,531-540,548,612,630
exit
!
port jumbo-frame
!
loopback-detection enable
loopback-detection interval 10
loopback-detection vlan-based
loopback-detection vlan-based recovery-time 60
!
errdisable recovery interval 120
errdisable recovery cause loopback-detection
errdisable recovery cause stp-bpdu-guard
errdisable recovery cause stp-loopback-guard
errdisable recovery cause unidirectional-link
errdisable recovery cause storm-control
!
vpc domain 1
 peer detection
 peer detection interval 200
 peer detection timeout 700
 peer detection ipaddr 10.80.3.44 10.80.3.45
 peer keepalive
 peer keepalive timeout 2
 role priority 10
 peer link Port-Channel 1
exit
!
!
hostname SWG_OIT_SFP2
!
line console
 exec-timeout 30
exit
!
line ssh
 exec-timeout 15
exit
!
username root password encrypted 0eb3d6ceb65c5f7f938ba393c4d667a2fe7b269e privilege 15
username admin password encrypted 81fd928162cdd2149ba3db96914f245abd8ac3a0 privilege 15
!
ip ssh server
!
no ip telnet server
!
interface gigabitethernet1/0/1
 description FOR_CTT
 switchport mode trunk
 switchport trunk allowed vlan add 503,535,540
exit
!
interface gigabitethernet1/0/10
 description CTT
 switchport mode trunk
 switchport trunk allowed vlan add 503,535,540
exit
!
interface gigabitethernet1/0/11
 ip address 1.1.1.2 255.255.255.252
exit
!
interface tengigabitethernet1/0/3
 channel-group 1 mode auto
exit
!
interface tengigabitethernet1/0/4
 shutdown
 channel-group 1 mode auto
exit
!
interface Port-channel1
 switchport mode trunk
 switchport trunk allowed vlan add 503,508-509,531-540,548,612,630
exit
!
interface vlan 1
 no ip address dhcp
exit
!
interface vlan 503
 name L2_CONTROL_AMURGEN_BTEC
 ip address 10.80.3.45 255.255.255.0
exit
!
!
ip default-gateway 10.80.3.1
!
!
end
SWG_OIT_SFP2#

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:16

Код: Выделить всё

SWG_OIT_SFP2#sh stack

Topology is Chain

Unit Id     MAC Address       Role
------- ------------------- --------
   1     e0:d9:e3:cb:78:40   master

SWG_OIT_SFP2#

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:17

Код: Выделить всё

SWG_OIT_SFP2#sh stack link

Topology is Chain

Unit Id     Active Links        Neighbor Links    Operational     Down/Standby
                                                  Link Speed      Links
------- -------------------- -------------------- ----------- --------------------
1                                                 NA

SWG_OIT_SFP2#

SWG_OIT_SFP2#sh stack conf

Unit Id  After Reboot Configuration

         Unit Id   Stack Links
-------- ------- ---------------
1        Auto

SWG_OIT_SFP2#


Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:18

Код: Выделить всё

SWG_OIT_SFP1#sh stack config

Unit Id  After Reboot Configuration

         Unit Id   Stack Links
-------- ------- ---------------
1        Auto

SWG_OIT_SFP1#

SWG_OIT_SFP1#sh stack links

Topology is Chain

Unit Id     Active Links        Neighbor Links    Operational     Down/Standby
                                                  Link Speed      Links
------- -------------------- -------------------- ----------- --------------------
1                                                 NA

SWG_OIT_SFP1#



Евгений Т
Сообщения: 1195
Зарегистрирован: 18 мар 2013 10:48
Reputation: 4
Откуда: Элтекс

Re: Разбор стэка MES2324FB проблема

Сообщение Евгений Т » 20 май 2020 15:43

Здравствуйте.

Код: Выделить всё

Порт с индексом 2 исчез, но при конфигурировании любого другого порта с индексом 2 разрешает.
Такое впечатление, что коммутаторы до сих пор думают, что они в стэке и видят второй юнит.

Коммутаторы моделей MES2300/3300/5324 всегда находятся в стеке. Просто для них стековые порты не настроены по дефолту и номер юнита 1.
Конфигурировать поэтому порты других юнитов даёт.
Евгений Тур / Элтекс / Сервисный центр ШПД / https://eltex-co.ru/support/

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 20 май 2020 15:51

Странно почему не обнулился один только порт?
Причем он пермещался с одного коммутатора на второй(ну как в стэке).

Евгений Т
Сообщения: 1195
Зарегистрирован: 18 мар 2013 10:48
Reputation: 4
Откуда: Элтекс

Re: Разбор стэка MES2324FB проблема

Сообщение Евгений Т » 21 май 2020 10:55

Здравствуйте.

Для понимания нужен весь исходный конфиг. Проверим в лаборатории тогда по описанным Вами действиям.
Евгений Тур / Элтекс / Сервисный центр ШПД / https://eltex-co.ru/support/

Maxik
Сообщения: 79
Зарегистрирован: 01 авг 2019 09:33
Reputation: 0

Re: Разбор стэка MES2324FB проблема

Сообщение Maxik » 21 май 2020 11:52

Здравствуйте.
Вообщем все убрал(обнулил), коммутатор заработал. Спасибо за помощь


Вернуться в «Коммутаторы и маршрутизаторы Ethernet»

Кто сейчас на конференции

Сейчас этот форум просматривают: Bing [Bot] и 1 гость