Помогите с настройкой сие чуда. Есть пара вопросов, может быть кто-то знает на них ответы.
Как то настроил на обоих коммутаторах, вот кусочки конфигов. (Свичи буду нумеровать так как у меня чтобы самому не запутаться)
sw7_mes5332a(config)#do show running-config
Код: Выделить всё
spanning-tree mode mst
!
vlan database
vlan 10,100
exit
!
port jumbo-frame
!
vpc
vpc domain 1
peer detection
peer detection interval 200
peer detection timeout 700
peer detection ipaddr 10.10.10.14 10.10.10.13
peer keepalive
role priority 1
peer link port-channel 1
exit
!
vpc group 1
domain 1
vpc-port port-channel 2
exit
!
!
hostname sw7_mes5332a
!
interface TenGigabitEthernet1/0/28
description sw8-te1/0/28
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/29
description sw8-te1/0/29
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/30
description sw8-te1/0/30
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/31
description sw2_eth1/30
channel-group 2 mode on
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/32
speed 1000
description sw5_gi1/0/1
channel-group 3 mode on
switchport mode trunk
exit
!
interface Port-Channel1
description sw8-interlink
switchport mode trunk
switchport trunk allowed vlan add 100
exit
!
interface Port-Channel2
speed 10000
description nexus-uplink
switchport mode trunk
switchport trunk allowed vlan add 10,100
exit
!
interface Port-Channel3
speed 1000
description sw5-downlink
switchport mode trunk
switchport trunk allowed vlan add 10,100
exit
!
interface vlan 1
ipv6 address autoconfig
ipv6 address dhcp
exit
!
interface vlan 10
name main-netwwork
exit
!
interface vlan 100
name managment
ip address 10.10.100.7 255.255.255.0
exit
!
interface oob
ip address 10.10.10.13 255.255.255.252
no ip address dhcp
exit
!
!
ip default-gateway 10.10.100.200
!
end
sw7_mes5332a(config)#
sw8_mes5332a(config)#do show running-config
Код: Выделить всё
spanning-tree mode mst
!
vlan database
vlan 10,100
exit
!
port jumbo-frame
!
vpc
vpc domain 1
peer detection
peer detection interval 200
peer detection timeout 700
peer detection ipaddr 10.10.10.13 10.10.10.14
peer keepalive
role priority 2
peer link port-channel 1
exit
!
vpc group 1
domain 1
vpc-port port-channel 2
exit
!
!
hostname sw8_mes5332a
!
interface TenGigabitEthernet1/0/27
description sw7-te1/0/27
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/28
description sw7-te1/0/28
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/29
description sw7-te1/0/29
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/30
description sw7-te1/0/30
channel-group 1 mode auto
switchport mode trunk
exit
!
interface TenGigabitEthernet1/0/31
description sw3_eth1/29
channel-group 2 mode auto
switchport mode trunk
exit
!
interface Port-Channel1
description sw7-interlink
switchport mode trunk
switchport trunk allowed vlan add 100
exit
!
interface Port-Channel2
description nexus-uplink
switchport mode trunk
switchport trunk allowed vlan add 10,100
exit
!
interface vlan 1
ipv6 address autoconfig
ipv6 address dhcp
exit
!
interface vlan 10
name main-network
exit
!
interface vlan 100
name managment
ip address 10.10.100.8 255.255.255.0
exit
!
interface oob
ip address 10.10.10.14 255.255.255.252
no ip address dhcp
exit
!
!
ip default-gateway 10.10.100.200
!
end
Сначала объясню как я всё это понимаю. Поправьте если я не прав.
На свичах интерфейсы te1/0/27-30 собраны в бонд и настроены как vpc peer-link в первом домене, мастером стоит sw7_mes5332a.
Свичи соединены между собой через OOB интерфейсы по которому происходит peer-detection через адреса 10.10.10.14 и 10.10.10.13
sw7_mes5332a(config)#do show vpc peer-detection
Код: Выделить всё
VPC domain 1
Peer IP address................................ 10.10.10.14
Source IP address.............................. 10.10.10.13
UDP port....................................... 50000
Peer detection admin status.................... Enabled
Peer detection operational status.............. Up
Peer is detected............................... detected
Configured Tx interval......................... 200 milliseconds
Configured Rx timeout.......................... 700 milliseconds
sw7_mes5332a(config)#do show vpc statistics peer link
Код: Выделить всё
Peer-link statistics:
VPC domain....................................... 1
Peer link........................................ Po1
Peer-Link status................................. Up
Peer link control messages Tx.................. 27
Peer link control messages Tx errors........... 0
Peer link control messages Tx timeout.......... 0
Peer link control messages ACK Tx.............. 413
Peer link control messages ACK Tx errors....... 0
Peer link control messages Rx.................. 413
Peer link data messages Tx..................... 13857
Peer link data messages Tx errors.............. 16
Peer link data messages Tx timeout............. 0
Peer link data messages Rx..................... 464
Peer link Bulk Tx to peer...................... 362
Peer link Bulk Tx timeout...................... 0
Peer link Bulk Tx errors....................... 1
Peer link Bulk Rx from peer.................... 166
Peer link Bulk Rx errors....................... 0
Peer link LACPDU Tx to peer.................... 388
Peer link LACPDU Tx errors..................... 0
Peer link LACPDU Rx from peer.................. 76
Peer link LACPDU Rx errors..................... 0
Peer link BPDU Tx to peer...................... 13590
Peer link BPDU Tx errors....................... 121
Peer link BPDU Rx from peer.................... 0
Peer link BPDU Rx errors....................... 0
Судя по тому что написано выше peer-link работает. Наверно )
На обоих свичах создана группа 1 в которую взят порт port-channel 2 на каждом свиче, которые смотрят каждый в сторону nexus5548 каждый порт в свой nexus. Nexusы настроены примерно по тому-же принципу. Их делал конечно не я а другой админ лет 8 назад но не важно. Суть в том что со стороны нексусов на нас смотрит тоже VPC со своей группой и т.д.
Вот что я вижу на MESах при всей этой настройке.
sw7_mes5332a(config)#do show interfaces Port-Channel2
Код: Выделить всё
Port-Channel2 is up (connected)
Interface index is 1001
Hardware is aggregated ethernet interface(s), MAC address is e4:5a:d4:40:0b:81
Description: nexus-uplink
Interface MTU is 9000
Link is up for 0 days, 3 hours, 13 minutes and 13 seconds
Link aggregation type is static LAG
No. of members in this port-channel: 2 (active 1)
TenGigabitEthernet1/0/31, full-duplex, 10000Mbps (active)
TenGigabitEthernet3/0/31, 0Mbps (non-candidate)
Active bandwidth is 10000Mbps
15 second input rate is 43 Kbit/s
15 second output rate is 56 Kbit/s
475283 packets input, 69640126 bytes received
56073 broadcasts, 74873 multicasts
0 input errors, 0 FCS
0 oversize, 0 internal MAC
0 pause frames received
361237 packets output, 83162916 bytes sent
7101 broadcasts, 9060 multicasts
0 output errors, 0 collisions
N/S excessive collisions, 0 late collisions
0 pause frames transmitted
Внимание на:
TenGigabitEthernet1/0/31, full-duplex, 10000Mbps (active)
TenGigabitEthernet3/0/31, 0Mbps (non-candidate)
sw8_mes5332a#show interfaces Port-Channel2
Код: Выделить всё
Port-Channel2 is up (connected)
Interface index is 1001
Hardware is aggregated ethernet interface(s), MAC address is e4:5a:d4:40:2e:81
Description: nexus-uplink
Interface MTU is 9000
Link is up for 0 days, 0 hours, 42 minutes and 57 seconds
Link aggregation type is LACP
No. of members in this port-channel: 2 (active 1)
TenGigabitEthernet1/0/31, full-duplex, LACP active, 10000Mbps (active)
TenGigabitEthernet3/0/31, LACP passive, 0Mbps (non-candidate)
Active bandwidth is 10000Mbps
15 second input rate is 5 Kbit/s
15 second output rate is 1 Kbit/s
27382 packets input, 2065632 bytes received
12919 broadcasts, 11703 multicasts
0 input errors, 0 FCS
0 oversize, 0 internal MAC
0 pause frames received
2982 packets output, 370072 bytes sent
215 broadcasts, 211 multicasts
0 output errors, 0 collisions
N/S excessive collisions, 0 late collisions
0 pause frames transmitted
Внимание на:
TenGigabitEthernet1/0/31, full-duplex, LACP active, 10000Mbps (active)
TenGigabitEthernet3/0/31, LACP passive, 0Mbps (non-candidate)
Вопрос:
что такое TenGigabitEthernet3/0/31?
такого интерфейса в show interfaces status нет. он прилетает от пира? тогда почему 0Mbps (non-candidate)? Его тоже надо настраивать или это норм что он в таком состоянии, не понятно.
Спасибо если дочитали до конца.