О деактивации форума Eltex

Уважаемые коллеги! В связи с потерей актуальности данного ресурса, нами было принято решение о частичной деактивации форума Eltex. Мы отключили функции регистрации и создания новых тем, а также возможность оставлять сообщения. Форум продолжит работу в "режиме чтения", так как за долгие годы работы здесь накопилось много полезной информации и ответов на часто встречающиеся вопросы.

Мы активно развиваем другие каналы коммуникаций, которые позволяют более оперативно и адресно консультировать наших клиентов. Если у вас возникли вопросы по работе оборудования, вы можете обратиться в техническую поддержку Eltex, воспользовавшись формой обращения на сайте компании или оставить заявку в системе Service Desk. По иным вопросам проконсультируют наши менеджеры коммерческого отдела: eltex@eltex-co.ru.

ERPS

MES, ESR
kisharra
Сообщения: 23
Зарегистрирован: 15 ноя 2022 14:45
Reputation: 0

ERPS

Сообщение kisharra » 03 янв 2023 07:48

Добрый день! А можно поинтересоваться примером настройки ERPS для схемы кольца, которую я указывал в предыдущих темах и для такой конфигурации комутатора (8 влан управляющий для данного кольца). Может ли быть на одном основном коммутаторе несколько R-APS VLAN, если в основном коммутаторе несколько отдельных подобных колец?

Код: Выделить всё

no spanning-tree
!
bridge multicast filtering
!
vlan database
 vlan 8,14,107
exit
!
loopback-detection enable
loopback-detection mode multicast-mac-addr
loopback-detection vlan-based
loopback-detection vlan-based recovery-time 300
!
ip dhcp relay address 10.156.10.1
ip dhcp relay address 10.156.10.2
ip dhcp relay enable
ip dhcp relay information option suboption-type custom
ip dhcp snooping
ip dhcp snooping information option allowed-untrusted
ip dhcp information option format-type option pv
ip dhcp snooping vlan 14
!
multicast snooping profile iptv_group238
 match ip 238.1.1.1 238.1.1.254
exit
!
multicast snooping profile hdtv_group237
 match ip 237.1.1.1 237.1.1.50
exit
!
multicast snooping profile prem_group237
 match ip 237.1.2.1 237.1.2.100
exit
!
!
ip igmp snooping
ip igmp snooping vlan 14
ip igmp snooping vlan 107 mrouter interface te1/0/1
ip igmp snooping vlan 107 immediate-leave host-based
!
ip arp inspection
ip arp inspection vlan 14
!
ip source-guard
!
qos advanced ports-trusted
qos advanced-mode trust dscp
!
ip access-list extended acl_video
 permit ip any any 192.168.1.248 0.0.0.0 any ace-priority 20
 permit ip any any 192.168.1.240 0.0.0.0 any ace-priority 21
exit
!
mac access-list extended acl_tv
 permit any any vlan 107 ace-priority 20
exit
!
ip access-list extended block_client_dhcp
 deny udp any any any bootpc ace-priority 20
 permit ip any any any any ace-priority 40
exit
!
!
class-map class_tv
 match access-group acl_tv
exit
!
class-map class_video
 match access-group acl_video
exit
!
policy-map pol_tv
 class class_tv
  set dscp 48
 exit
 class class_video
  set dscp 40
 exit
exit
!
!
hostname k75-1
!
management access-list ip_trust
 permit ip-source 10.156.10.1
 permit ip-source 10.156.10.2
 permit ip-source 10.156.10.10
exit
!
logging host 10.156.10.1
!
username sa password encrypted 775ad44a2f5c9569143f1b3352fee888f64ec01a privilege 15
!
snmp-server server
encrypted snmp-server community hXKI/nU2kUzqKGixTrnUEJk2X9/GnPd4ihiuEf9vIco= ro view Default
encrypted snmp-server community 5O2f0coreE59RGZehVQFBLTUClcrZ1HxxBXSx3yu8I0= rw view Default
!
clock timezone AMK +10
clock source sntp
!
sntp unicast client enable
sntp server 10.156.10.1 poll
!
backup server tftp://10.156.10.1
backup path swcontrol/mes2324/cfg10.8.7.1
backup time-period 1440
backup auto
!
interface gigabitethernet1/0/1
 loopback-detection enable
 ip source-guard
 rate-limit 100000 burst 1500000
 storm-control broadcast kbps 5000
 storm-control unicast level 5 trap
 spanning-tree bpdu filtering
 traffic-shape 100000 1500000
 service-acl input block_client_dhcp
 switchport mode general
 switchport general allowed vlan add 14 untagged
 switchport general multicast-tv vlan 107
 switchport general pvid 14
 switchport forbidden default-vlan
 multicast snooping add iptv_group238
 multicast snooping add hdtv_group237
 multicast snooping add prem_group237
 multicast snooping max-groups 6
exit
!
Остальные gi порты по аналогии
!
interface tengigabitethernet1/0/1
 ip arp inspection trust
 ip dhcp snooping trust
 ip dhcp relay enable
 service-policy input pol_tv default-action permit-any
 switchport mode general
 switchport general allowed vlan add 8,14,107 tagged
 switchport general acceptable-frame-type tagged-only
 switchport forbidden default-vlan
exit
!
interface tengigabitethernet1/0/2
 ip arp inspection trust
 ip dhcp snooping trust
 ip dhcp relay enable
 service-policy input pol_tv default-action permit-any
 switchport mode general
 switchport general allowed vlan add 8,14,107 tagged
 switchport general acceptable-frame-type tagged-only
 switchport forbidden default-vlan
exit
!
interface tengigabitethernet1/0/3
 ip arp inspection trust
 ip dhcp snooping trust
 ip dhcp relay enable
 service-policy input pol_tv default-action permit-any
 switchport mode general
 switchport general allowed vlan add 8,14,107 tagged
 switchport general acceptable-frame-type tagged-only
 switchport forbidden default-vlan
exit
!
interface tengigabitethernet1/0/4
 ip arp inspection trust
 ip dhcp snooping trust
 ip dhcp relay enable
 service-policy input pol_tv default-action permit-any
 switchport mode general
 switchport general allowed vlan add 8,14,107 tagged
 switchport general acceptable-frame-type tagged-only
 switchport forbidden default-vlan
exit
!
interface vlan 8
 ip address 10.8.7.1 255.255.0.0
exit
!
interface vlan 14
 ip dhcp relay enable
exit
!
!
ip default-gateway 10.8.10.1
!
end
Вложения
рисунок 1.png
рисунок 1.png (15.38 КБ) 1602 просмотра

Konstantin D
Сообщения: 30
Зарегистрирован: 02 дек 2022 14:07
Reputation: 1

Re: ERPS

Сообщение Konstantin D » 09 янв 2023 17:11

Добрый день.
Если у вас vlan-ы в кольцах полностью разделены и не переходят из одного кольца в другое, то можно использовать отдельный R-APS VLAN для каждого кольца.
Если имеются vlan-ы, переходящие из одного кольца в другое, то для конфигурации воспользуйтесь следующим примером:
https://docs.eltex-co.ru/pages/viewpage ... d=45461800
С уважением,
Демченко Константин
Сервисный центр ШПД
ООО "Предприятие "Элтекс"

kisharra
Сообщения: 23
Зарегистрирован: 15 ноя 2022 14:45
Reputation: 0

Re: ERPS

Сообщение kisharra » 10 янв 2023 14:30

Под свою схему я сделал такой конфиг, правильный ли он? Еще меня интересует, как сделать так, чтобы происходило блокирование линка (X) (как на схеме), то есть от одного коммутатора с двух портов уходит два "Плеча", которые работают отдельно при блокировании линка между двумя крайними коммутаторами в самом конце схемы. P.S. порт te1/0/1 в коммутаторе 1 у меня задействован для удаленного доступа, его можно не учитывать.

Код: Выделить всё

Конфигурация коммутатора 1:

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# ring enable

console(config-erps)# port west te1/0/2

console(config-erps)# port east te1/0/3

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# rpl west owner

console(config-erps)# exit

console(config)#

console(config)# interface range TengigabitEthernet1/0/1-2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# spanning-tree bpdu filtering

Конфигурация коммутатора 2:

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# ring enable

console(config-erps)# port east te1/0/1

console(config-erps)# port west te1/0/2

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# rpl west neighbor

console(config-erps)# exit

console(config)#

console(config)# interface range TengigabitEthernet1/0/1-2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# spanning-tree bpdu filtering

Конфигурация коммутаторов 3

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# ring enable

console(config-erps)# port east tengigabitethernet1/0/1

console(config-erps)# port west tengigabitethernet1/0/2

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)#

console(config)# interfaceTengigabitEthernet1/0/1

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# interfaceTengigabitEthernet1/0/2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

Конфигурация коммутаторов 4

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# ring enable

console(config-erps)# port east tengigabitethernet1/0/1

console(config-erps)# port west tengigabitethernet1/0/2

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)#

console(config)# interfaceTengigabitEthernet1/0/1

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# interfaceTengigabitEthernet1/0/2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

Конфигурация коммутаторов 5

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# ring enable

console(config-erps)# port east tengigabitethernet1/0/1

console(config-erps)# port west tengigabitethernet1/0/2

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)#

console(config)# interfaceTengigabitEthernet1/0/1

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# interfaceTengigabitEthernet1/0/2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit
Вложения
схема.PNG
схема.PNG (21.63 КБ) 1397 просмотров

Konstantin D
Сообщения: 30
Зарегистрирован: 02 дек 2022 14:07
Reputation: 1

Re: ERPS

Сообщение Konstantin D » 12 янв 2023 16:51

1) Команда "spanning-tree bpdu filtering" должна быть установлена на всем кольце.
2) Ваш линк Х - это rpl link, который в нормальном состоянии блокирован. rpl link находится между портами
owner и neighbor. Для вашей задачи это коммутатор 3 порт tengigabitethernet1/0/2 и коммутатор 4 порт tengigabitethernet1/0/1.
С уважением,
Демченко Константин
Сервисный центр ШПД
ООО "Предприятие "Элтекс"

kisharra
Сообщения: 23
Зарегистрирован: 15 ноя 2022 14:45
Reputation: 0

Re: ERPS

Сообщение kisharra » 13 янв 2023 06:57

Все получилось, схема заработала как я хотел, но вылезла одна странность неприятная. В месте где произошел разрыв и перестроение кольца после прохождения WTR 5 минут блокируется порт и одновременно с этим блокируется RPL линк. На данном выводе show erps видно что заблокирован на 3 коммутаторе te1/0/1, а на 4 - te1/0/2. В другом тесте разорвал линк межу 4 и 5 коммутаторами и вот после wtr
какие пинги пошли

Код: Выделить всё

Конфигурация коммутатора 1:

console(config)# vlan database

console(config-if)# vlan 10

console(config-if)# exit

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# port west tengigabitethernet1/0/2

console(config-erps)# port east tengigabitethernet1/0/3

console(config-erps)# ring enable

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)# interface range TengigabitEthernet1/0/2-3

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# spanning-tree bpdu filtering



Конфигурация коммутатора 2:

console(config)# vlan database

console(config-if)# vlan 10

console(config-if)# exit

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# port west tengigabitethernet1/0/1

console(config-erps)# port east tengigabitethernet1/0/2

console(config-erps)# ring enable

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)# interface range TengigabitEthernet1/0/1-2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

console(config)# spanning-tree bpdu filtering



Конфигурация коммутаторов 3

console(config)# vlan database

console(config-if)# vlan 10

console(config-if)# exit

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# port west tengigabitethernet1/0/1

console(config-erps)# port east tengigabitethernet1/0/2

console(config-erps)# rpl west neighbor

console(config-erps)# ring enable

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)# interfaceTengigabitEthernet1/0/1-2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit



Конфигурация коммутаторов 4

console(config)# vlan database

console(config-if)# vlan 10

console(config-if)# exit

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# port west tengigabitethernet1/0/2

console(config-erps)# port east tengigabitethernet1/0/1

console(config-erps)# rpl west owner

console(config-erps)# ring enable

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)# interfaceTengigabitEthernet1/0/1-2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit



Конфигурация коммутаторов 5

console(config)# vlan database

console(config-if)# vlan 10

console(config-if)# exit

console(config)# no spanning-tree

console(config)# erps

console(config)# erps vlan 10

console(config-erps)# port west tengigabitethernet1/0/2

console(config-erps)# port east tengigabitethernet1/0/1

console(config-erps)# ring enable

console(config-erps)# protected vlan add 8,14,107

console(config-erps)# exit

console(config)# interfaceTengigabitEthernet1/0/1-2

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 8,10,14,107

console(config-if)# switchport forbidden default-vlan

console(config-if)# exit

Код: Выделить всё

Коммутатор 1:

R-APS VLAN : 10
Admin Status : Enabled
West Port : te1/0/2 (Forwarding)
East Port : te1/0/3 (Forwarding)
RPL Port : None
RPL Owner : Disabled
Protected VLANs :
8,14,107
Ring MEL : 1
Holdoff Time : 0 msec
Guard Time : 500 msec
WTR Time : 5 min
Current Ring State : Idle
Revertive : Yes
Compatibility with version : 2

Sub-Ring R-APS VLAN TC Propagation State
------------------- --------------------

Total Sub-Rings Connected : 0

Коммутатор 2:

R-APS VLAN : 10
Admin Status : Enabled
West Port : te1/0/1 (Forwarding)
East Port : te1/0/2 (Forwarding)
RPL Port : None
RPL Owner : Disabled
Protected VLANs :
8,14,107
Ring MEL : 1
Holdoff Time : 0 msec
Guard Time : 500 msec
WTR Time : 5 min
Current Ring State : Idle
Revertive : Yes
Compatibility with version : 2

Sub-Ring R-APS VLAN TC Propagation State
------------------- --------------------

Total Sub-Rings Connected : 0

Коммутатор 3:

R-APS VLAN : 10
Admin Status : Enabled
West Port : te1/0/1 (Blocking)
East Port : te1/0/2 (Forwarding)
RPL Port : West
RPL Owner : Disabled
Protected VLANs :
8,14,107
Ring MEL : 1
Holdoff Time : 0 msec
Guard Time : 500 msec
WTR Time : 5 min
Current Ring State : Idle
Revertive : Yes
Compatibility with version : 2

Sub-Ring R-APS VLAN TC Propagation State
------------------- --------------------

Total Sub-Rings Connected : 0

Коммутатор 4:

R-APS VLAN : 10
Admin Status : Enabled
West Port : te1/0/2 (Blocking)
East Port : te1/0/1 (Forwarding)
RPL Port : West
RPL Owner : Enabled (Active)
Protected VLANs :
8,14,107
Ring MEL : 1
Holdoff Time : 0 msec
Guard Time : 500 msec
WTR Time : 5 min
Current Ring State : Idle
Revertive : Yes
Compatibility with version : 2

Sub-Ring R-APS VLAN TC Propagation State
------------------- --------------------

Total Sub-Rings Connected : 0

Коммутатор 5:

R-APS VLAN : 10
Admin Status : Enabled
West Port : te1/0/2 (Forwarding)
East Port : te1/0/1 (Forwarding)
RPL Port : None
RPL Owner : Disabled
Protected VLANs :
8,14,107
Ring MEL : 1
Holdoff Time : 0 msec
Guard Time : 500 msec
WTR Time : 5 min
Current Ring State : Idle
Revertive : Yes
Compatibility with version : 2

Sub-Ring R-APS VLAN TC Propagation State
------------------- --------------------

Total Sub-Rings Connected : 0
Вложения
erps.PNG
erps.PNG (176.47 КБ) 1317 просмотров

Konstantin D
Сообщения: 30
Зарегистрирован: 02 дек 2022 14:07
Reputation: 1

Re: ERPS

Сообщение Konstantin D » 13 янв 2023 12:38

Добрый день.

Для более детального разбора прошу завести обращение по форме
https://eltex-co.ru/support/
Туда же приложите указанную информацию, а так же show tech со всех коммутаторов кольца и схему кольца с подписанными портами.
С уважением,
Демченко Константин
Сервисный центр ШПД
ООО "Предприятие "Элтекс"

kisharra
Сообщения: 23
Зарегистрирован: 15 ноя 2022 14:45
Reputation: 0

Re: ERPS

Сообщение kisharra » 14 янв 2023 06:39

Спасибо за помощь, я в принципе разобрался, и схема заработала. Но есть такой вопрос, который я уже задавал, по поводу нескольких колец на одном коммутаторе. Если у меня условно несколько зон с кольцами от одного коммутатора с разными Vlan, но есть один общий для мультикаста и он используется для всей сети к примеру из 700 коммутаторов, будет ли схема работать или нужно использовать "Подкольца", и сколько таких сабколец можно создать на одном коммутаторе?

Konstantin D
Сообщения: 30
Зарегистрирован: 02 дек 2022 14:07
Reputation: 1

Re: ERPS

Сообщение Konstantin D » 17 янв 2023 17:55

Т.к. у вас есть общий vlan то, как говорилось ранее, вам нужны подкольца.
"Если имеются vlan-ы, переходящие из одного кольца в другое, то для конфигурации воспользуйтесь следующим примером:
https://docs.eltex-co.ru/pages/viewpage ... d=45461800
"
Т.к. при разрыве и перестроении кольца мультикаст может быть потерян до следующей отправки IGMP Query (до 120 секунд) рекомендуем для колец с мультикаст vlan на каждом порту кольца настроить mrouter. Это позволит постоянно передавать мультакаст по кольцу, что предотвратит длительный разрыв мультикаста.
С уважением,
Демченко Константин
Сервисный центр ШПД
ООО "Предприятие "Элтекс"


Вернуться в «Коммутаторы и маршрутизаторы Ethernet»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 5 гостей